How to build your own ep embedded image.

The Collective will serve as a tips and tricks area. Information here will be contributed only by moderators and will hopefully act as a reference point. If you have information that should be in here please let us know

Re: How to build your own ep embedded image.

Postby whiteflash » Thu May 28, 2009 1:57 pm

I reverted back to trying to boot from CD.  I still get the stop error, but it seems to get past it after a few restarts.  I now have my build installed properly.

Has anyone tackled standby/hibernation?


thanks,



Chris
whiteflash
Newbie
Newbie
 
Posts: 3
Joined: Tue May 26, 2009 8:40 pm

Re: How to build your own ep embedded image.

Postby HyperNewb » Thu May 28, 2009 2:38 pm

standby works if you include the video drives in the build
HyperNewb
Developer
Developer
 
Posts: 21
Joined: Wed Apr 01, 2009 1:15 am

Re: How to build your own ep embedded image.

Postby whiteflash » Thu May 28, 2009 6:45 pm

Are you talking about GX2_XP_XPe_Graphics or the PenMount Driver?  I added them to the database, and I think I added them properly to the build.  Am I missing something, because I don't have any stand-by options under Power in the Control Panel.

Thanks,


Chris
whiteflash
Newbie
Newbie
 
Posts: 3
Joined: Tue May 26, 2009 8:40 pm

Re: How to build your own ep embedded image.

Postby HyperNewb » Fri May 29, 2009 3:31 am

I'm new to this kind of thing so I please bare with me and any advice I have ;D. In the last build I did I added a few new components in addition to the video drivers. Off the top of my head I'm thinking that if you aren't getting stand by with the installed video drivers that perhaps it could be a combination of that and the screen saver shell component?
HyperNewb
Developer
Developer
 
Posts: 21
Joined: Wed Apr 01, 2009 1:15 am

Re: How to build your own ep embedded image.

Postby ionbladez » Mon Jun 01, 2009 9:10 pm

Ok, well it seems I've messed it up. The whole thing.
I didn't exactly know what you mean by "Insert the embedded CD and boot from it" since I did not download or make an ISO of any kind.

I used a windows xp Pro disc, booted fine, but I got to the recovery prompt and typed "diskpart", it came up fine.
anyways I deleted the partition, it says New (Raw) now; but now it won't let me format it. It complains about not being a disk in the drive or something close to it.
I haven't got the thing to start anyways.
ionbladez
Jr. Member
Jr. Member
 
Posts: 53
Joined: Sun Apr 05, 2009 8:25 pm
Location: Coral Springs, Florida

Re: How to build your own ep embedded image.

Postby manko » Wed Jun 03, 2009 1:11 pm

Hello everyone. Iv been lurking around for a bit but and i see that this is the best place for webdt owners out there.

I have currently win ce installed, but i like to make an XPe, but even after installing sp2 and featurepack 2007 i still get errors when i try to webdtxpefinal.slx in target designer.

Code: Select all
Starting configuration activation at: 03.06.2009 22:01:03...
CFDB: 1,02 secs, 35 reqs. LAB: 1,02 secs, 35 reqs, 0% hits, 0 entries
Activation complete, elapsed time: 37,73 seconds
No errors or warnings

Error    1101: Missing component in database during upgrade of : "Primitive: xmllite.dll [Version 5.1.2600.4010, R4010]"
Error    1117: Cannot upgrade : "Primitive: xmllite.dll [Version 5.1.2600.4010, R4010]"
Error    1101: Missing component in database during upgrade of : "Internationalized Domain Names Mitigations APIs [Version 5.1.2600.4010, R4010]"
Error    1117: Cannot upgrade : "Internationalized Domain Names Mitigations APIs [Version 5.1.2600.4010, R4010]"
Error    1101: Missing component in database during upgrade of : "Windows XP Service Pack 3 Resource DLL - Security Update KB932168 [Version 5.1.2600.2900.1, R3350]"
Error    1117: Cannot upgrade : "Windows XP Service Pack 3 Resource DLL - Security Update KB932168 [Version 5.1.2600.2900.1, R3350]"
Error    1101: Missing component in database during upgrade of : "Windows Media Format Runtime 11 [Version 5.1.2600.4010, R4010]"
Error    1117: Cannot upgrade : "Windows Media Format Runtime 11 [Version 5.1.2600.4010, R4010]"
Error    1101: Missing component in database during upgrade of : "Microsoft Feeds Manager [Version 5.1.2600.4010, R4010]"
Error    1117: Cannot upgrade : "Microsoft Feeds Manager [Version 5.1.2600.4010, R4010]"
Error    1101: Missing component in database during upgrade of : "Windows User Mode Driver Framework [Version 5.1.2600.4010, R4010]"
Error    1117: Cannot upgrade : "Windows User Mode Driver Framework [Version 5.1.2600.4010, R4010]"
Error    1101: Missing component in database during upgrade of : "Microsoft Compression Engine [Version 5.1.2600.4010, R4010]"
Error    1117: Cannot upgrade : "Microsoft Compression Engine [Version 5.1.2600.4010, R4010]"


I havent tried to buildt it. Will it work annyhow? I guess not...

PMs with a workaround would also be appreciated ;)

Thanks..
manko
Newbie
Newbie
 
Posts: 18
Joined: Wed Jun 03, 2009 1:05 pm

Re: How to build your own ep embedded image.

Postby HyperNewb » Wed Jun 03, 2009 3:28 pm

ah k, you have reached the point where you want to smash your head into a wall:) Install this "update rollup 1" http://www.microsoft.com/downloads/deta ... layLang=en It's and iso so you are going to need to burn it to a CD or use a virtual cd drive to get to the installer on the disc. One you install this into your repository you should be fine to go ahead and follow the rest of the tutorial.
Last edited by HyperNewb on Wed Jun 03, 2009 10:41 pm, edited 1 time in total.
HyperNewb
Developer
Developer
 
Posts: 21
Joined: Wed Apr 01, 2009 1:15 am

Re: How to build your own ep embedded image.

Postby manko » Wed Jun 03, 2009 5:24 pm

Yes i was ready to smash my head. But now everything works just fine :) Tanks a bunch!

In an ideal world i would fit dotnet 1 and 2 on this XPe. Is there something i can do without in this image?

That's probably a very foggy question. Is there somthing here you normaly could do without?
Probably not since its already slimmed down, but i have to ask :)
manko
Newbie
Newbie
 
Posts: 18
Joined: Wed Jun 03, 2009 1:05 pm

Re: How to build your own ep embedded image.

Postby HyperNewb » Wed Jun 03, 2009 10:38 pm

Added
network provisioning service (wpa)
screen saver shell and screen savers
video drivers (make sure you add them to the build after you add them to the repository)
user control panel (edit users)
time control panel (ability to change the time)
windows cleanup utilities
automatic logon

Removed
indexing service
shadow volume copy
defragmenting core and the other defragmenting items associated with it

Things that baffled me:)
* Advanced Configuration and Power Interface settings tab contains settings for system identification like workgroup and computer name. You may or may not want to change the settings meat put in his build:)

*If your build won't save settings you have the ewf manager enabled. In command prompt� use this command
� ewfmgr c: -disable. To start it back up again ewfmgr c: -enable to start it again.

*slds wont load into the repository. This happens when the repositories become read only. You'll have to rename the folder then change it back and share it again.


hope this all helps
HyperNewb
Developer
Developer
 
Posts: 21
Joined: Wed Apr 01, 2009 1:15 am

Re: How to build your own ep embedded image.

Postby manko » Thu Jun 04, 2009 4:44 pm

Thansk again :)
My image is bulidt, but guess what?
Cant use disk 1 to boot. It will however boot on my msi wind...
The webdt will not boot from cd rom. nor any of the usb keys i have tested. 


The method mentioned here viewtopic.php?t=7 didnt work either. I got error messages about it not finding dos system files, and once it just didnt copy the files to the usb thumb. I tried 3 different udb thunbs and also diferent computers.

And i cant find a bios upgrade either. So now am actally smashing my head against the wall :)
manko
Newbie
Newbie
 
Posts: 18
Joined: Wed Jun 03, 2009 1:05 pm

Re: How to build your own ep embedded image.

Postby plane_crazy » Fri Jun 05, 2009 7:49 am

Try using this tool to format the stick. Worked for me!

http://www.adrive.com/public/0400607f89 ... c1ecb.html

Use it with these files to make it bootable to Win98. Try this then delete the files from the stick, the bootsector will have already been created. http://www.adrive.com/public/e21f6726e8 ... da13c.html

Or you can use this one. It will boot up in Linux. http://www.adrive.com/public/0e41b4af12 ... ec52c.html

Bruce
Last edited by plane_crazy on Fri Jun 05, 2009 8:34 am, edited 1 time in total.
plane_crazy
plane_crazy
Full Member
Full Member
 
Posts: 112
Joined: Fri Apr 24, 2009 5:20 pm
Location: Sussex, New Brunswick, CAN

Re: How to build your own ep embedded image.

Postby quotaholic » Fri Jun 05, 2009 3:02 pm

Ok, what bios version do you have?

It took me 5 usb sticks to find one that worked and even then I needed to spoon feed it. I use a targus passive hub (walmart sale) and cant have anything else plugged in but the external drive. Once I see it start to take I can then plug the keyboard in. If I leave it all plugged in I get the same results as you.

Only other thing I can think of is that the first partition on the thumb drive is the default boot volume. Any chance you have multiple partitions?

quotaholic
quotaholic
Administrator
Administrator
 
Posts: 552
Joined: Tue Mar 24, 2009 9:11 pm

Re: How to build your own ep embedded image.

Postby manko » Sat Jun 06, 2009 8:28 am

Hi again,
my bios version is XpressROM_BIOS_DT366_0_01.18 Built: 07/01/2005.

I tried a lot of sticks, and tried the cd-rom without the hub.

I tried Plane_crazys suggestion and i came further but still no success. Thanks by the way :)

As it stand now:
My stick gets the c drive letter. I don't know how to work that out. So i tried formatting the d drive with a /s parameter and it looked ok. The WEBDT do not find my CFcard (4gb sandisk ultra II)so i copied the files over to my bootable stick and in dos i copied the files and folders over to the d drive. Well no success, as i suspected. 

I had some linux people take a look at the device, and they could not mount the CF card because they didn't find it with slax. But the slax stick booted just fine.

I haven't not been using diskpart, as i cant find it on disk one, and the ones i find on the net is giving me the error that it can not be used in command or something.

Totally i think the total man hours on this is 30-40 hours with testing and failing :)

Any suggestions? :)

Thanks
manko
Newbie
Newbie
 
Posts: 18
Joined: Wed Jun 03, 2009 1:05 pm

Re: How to build your own ep embedded image.

Postby quotaholic » Sat Jun 06, 2009 11:11 am

Slax is a great tool and it commonly automounts any attached media during boot.

One can check this with a:
Code: Select all
fdisk -l


How many drives do you see on that? Should be something like one for internal flash, one for the drive that slax is on. Hopefully you see a third for your cf card.

I wonder if the problems with the linux folk not being able to mount the cf card deals with the drives being already mounted?

If not it sounds like we may have to look at the bios. I will have to check with someone on that exact number. Before a certain point usb booting was not supported. I cant remember the exact revision but thank you for posting. I will get back to you on it.

quotaholic
quotaholic
Administrator
Administrator
 
Posts: 552
Joined: Tue Mar 24, 2009 9:11 pm

Re: How to build your own ep embedded image.

Postby quotaholic » Sun Jun 07, 2009 7:53 am

Well that bios revision is one that allows for booting from the usb however I took some notes as I reinstalled an os in to the the morning hours last night. Until I put in a significant number of packages on my os I was not able to mount the cf slot either. I could see the addressing take place on the hardware level but until I put in the software for volume management in linux it just wouldn't take. Usb however was fine.

As you can boot to slax on a usb stick you have eliminated bios, as well as media concerns. From that usb stick it is possible. Do you have any more sticks of that brand? Try the bios defaults and then trial by elimination. Can that media and that cdrom boot on another regular computer?
quotaholic
Administrator
Administrator
 
Posts: 552
Joined: Tue Mar 24, 2009 9:11 pm

PreviousNext

Return to The Collective

Who is online

Users browsing this forum: No registered users and 1 guest

cron

x